Troubleshooting Xero Export
Validation Exception Error
Possible Reasons
Solutions
- Check leave items in the timesheets, and use this to match the leave name in Xero - they must match
- If pay rates have been changed recently, re-sync the employee, or re-approve the timesheet
- Check leave names in ClickTime and edit them to match in Xero
Employees Not Found
Possible Reasons
Solutions
- Check & make sure names and emails match exactly in Xero and ClickTime.
Invalid Leave Period Provided
Solutions
Timesheet is not a Draft Timesheet
Possible Reasons
Solutions
Timesheet already exists/Timesheet cannot be overwritten
Possible Reasons
Solutions
Pay Element not found
Possible reasons
If you're utilizing ClickTime Pay Templates & Overtime, it's essential to ensure there's a corresponding
Pay Item in Xero that matches the Pay Category/Export code used on your ClickTime Pay Template.
The Payroll Category/Export Codes defined in ClickTime must be mirrored in Xero as Earning Rates,
and both need to be in perfect alignment.
Solutions
In Xero, go to Settings > Payroll Settings > Pay Items. Check the relevant Pay Item or create it if it wasn't there
You will need to make sure that:
Each employee has an Ordinary Earnings Rate
This earnings rate must be a pay rate with the type "Ordinary Time Earnings"
The Rate Type field set to "Rate per Unit", "Fixed Amount" or "Multiple of employee's ordinary earning rate". Consult with your account
If the The Rate Type is set to "Rate Per Unit", then the [ Type of Units] field must be set to "Hours". If it is not, you will receive a "Pay Element Not Found" error when exporting
- For overtime, you can set the Rate Type to "Multiple of employee's ordinary earning rate", and set the multiplier to be 1.5 or 2.0 or whatever value you desire based on your business needs. Consult with your account on how to configure overtime in XERO
Click the below image to see an example of an earning rate pay item created in Xero
Rates exported to Xero (from ClickTime) are wrong, even AFTER re-syncing the employee and re-approving the timesheet
Possible Reasons
Solutions
Check if there's a duplicate employee in Xero (check under history)
Check if employee shares an email in Xero with another employee
This timesheet already exists, please provide the timesheet ID
Possible Causes
1. Ensure that you have selected the correct Pay Cycle or Period in ClickTime for export. It's important to confirm that the chosen Pay Cycle aligns with the Pay Run in Xero
2. ClickTime cannot replace/update existing timesheets in Xero. If you need
to update the timesheets in Xero, the draft timesheets in the Xero Payrun need to be deleted before you can re-send from ClickTime
Superannuation Error
Possible Reasons
Solutions
Scope Not Recognised
Possible Reasons
Solutions
Earnings Rate Does not Exist or Invalid / Pay Category - Export Code Dose Not Exist or Invalid
Solutions
Employee XX doesn't have an ordinary earning rate
Make sure the employee profile in Xero is assigned an ordinary earning rate.
Go to Employee > Employment , Make sure the employment type is set to "Salary & Wages"
Error message: An Invalid Pay Item Has been used in your Xero Payroll
Fix 1:
Check pay item’s on the erroring timesheet are set up correctly in Xero under payroll Settings.
ClickTime requires the item to be set to Rate Per Unit with Unit Type Hours. They Can also be set up as a “Multiple of employees ordinary earnings Rate”.
It is also Important to check that there are no spaces added to the end of the Earnings Name or Type of units Field.
Export Failed - Employee - happens when retrieving data of this Employee from Xero
Solutions
No Payroll Calendar found
Possible Reasons
Solutions
Check Payroll Calendar exists. This can be seen within settings > payroll settings > calendars.
The Payroll calendar that you're exporting for should have dates that match with the pay period (dates) that you're exporting Timesheets for in ClickTime.
Check that the Payroll calendar is assigned to the profiles of the staff in Xero. This can be seen by going to payroll > employees > select employee > employment > pay calendar.
if there is an active pay run, try to delete the pay run
Error message: An Unknown Error Occurred
The majority of the time, this can be fixed by
disconnecting and reconnecting your Xero account from ClickTime
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